Author Topic: Problems with Winamp support?  (Read 12264 times)

0 Members and 1 Guest are viewing this topic.

GTS

  • Administrator
  • Addicted
  • *****
  • Posts: 524
  • Karma: +2/-0
  • GTSdll Author
    • GTSdll Homepage
Problems with Winamp support?
« on: March 08, 2006, 12:22:23 PM »
Winamp 5.20 introduced a new feature, that could mess with GTSdll.

To be more specific, it could be that GTSdll does not display the song you are playing, but some different one. Also it won't be able to display tags like album, genre or tracknumber. To fix that you'll need to set the correct directory in GTSdll Settings.


(this screen appears on winamp 5.2 installation)

If you select Shared settings for all users you'll need to set the winamp Directory in GTSdll settings to the installation directory of winamp.
Usually C:\Program Files\Winamp\
If you had GTSdll installed before, you probably don't need to change anything.

But if you select Seperate settings per user account you need to set the directory to %appdata%\Winamp.
Usually something like  C:\Documents and Settings\USERNAME\Application Data\Winamp\ on Windows XP
and something like C:\Users\USERNAME\AppData\Roaming\Winamp\ on Windows Vista.

The red part ~usually~ needs to be replaced by the name you use to log on into windows. It can differ!
To be asolutely sure, right click on your "my documents" folder, and check the path in there.
« Last Edit: October 05, 2007, 09:40:07 PM by GTS »
---> GTSdll Homepage <---

GTS

  • Administrator
  • Addicted
  • *****
  • Posts: 524
  • Karma: +2/-0
  • GTSdll Author
    • GTSdll Homepage
Re: Winamp 5.20 (and later) and GTSdll
« Reply #1 on: May 10, 2006, 11:12:00 AM »
Hm, i had no problems at all with latest (5.21) winamp, and i can't think of anything that stops gtsdll from working correctly with winamp, except the directory thingy.
I think winamp support is the only "it always works" thing on gtsdll.
---> GTSdll Homepage <---

blackwind

  • Guest
Re: Winamp 5.20 (and later) and GTSdll
« Reply #2 on: May 10, 2006, 12:17:49 PM »
Just figured it out -- I forgot to add a trailing backslash when I changed my path to the %APPDATA% one. Might be a good idea to add a check for that in a future release. :)

GTS

  • Administrator
  • Addicted
  • *****
  • Posts: 524
  • Karma: +2/-0
  • GTSdll Author
    • GTSdll Homepage
Re: Winamp 5.20 (and later) and GTSdll
« Reply #3 on: May 10, 2006, 02:36:59 PM »
Ah, okay ^^

Thx for that tipp ;)
---> GTSdll Homepage <---